読者です 読者をやめる 読者になる 読者になる

Diary over Finite Fields

515ひかるが書き溜めたメモとコラムと雑記

微妙にハマった話

エディタ 短い記事
pip install neovim

とかしても、 NeoVim で :UpdateRemotePlugins しても Not Found Module 'neovim' などというエラーが発生したので、メモ。

原因は、使用している Python を明記してなかったことにあった。以前、 pyenv & anaconda 環境に切り替えたのだが、 init.vim

let g:python_host_prog = '/usr/bin/python'
let g:python3_host_prog = '/usr/bin/python3'

と記述していたため、システムの Python を使い続けていた。以下のような pyenv 以下の Anaconda の環境を使うように教える必要がある。

let g:python_host_prog = '/usr/bin/python2'
let g:python3_host_prog = '$PYENV_ROOT/versions/anaconda3-4.2.0/bin/python'

version 番号などは自分の環境などに合わせて変えてください。

これだけのことなのだが無駄に時間を食ってしまった。うーむ、悲しい。